Simulateur de lancers de dés Excel sans macro avec nombre de lancers réglable

Pour l’étude des probabilités, que ce soit niveau seconde, CAP, … et le lien avec la loi des grands nombres, il peut être utile d’avoir un simulateur de lancers de dés Excel.

Simulateur de lancers de dés

Le simulateur de lancers de dés Excel

Ce simulateur de lancers de dés a été réalisé avec Excel, sans utilisation de macro, en permettant quand même à l’élève ou l’étudiant(e) de choisir le nombre de lancers.

L’élève choisit par exemple 4000 lancers et le simulateur lui affiche le nombre de fois où le chiffre 6 a été obtenu :

Simulateur de lancers de dés Excel sans macros

L’élève peut ensuite calculer la fréquence du nombre de « 6 » obtenus.

Le nombre de lancers possibles va de 1 à 50000. 50000 lancers permettant d’avoir une fréquence qui devient assez proche de la probabilité d’obtenir un 6 (environ 0,167).

Explication des formules

  • En G1, on simule un premier lancer de dé : =ALEA.ENTRE.BORNES(1;6), puis on étire cette formule jusqu’à la ligne voulue (50 000 dans le simulateur de base, pour simuler 50 000 lancers au maximum).
  • En B5, pour afficher le nombre de « 6 » obtenus =NB.SI(G1:INDIRECT(« J »&B3;6)) :
    • INDIRECT(« J »&B3) permet d’obtenir la dernière cellule de la plage qui sera utilisée dans le NB.SI. Par exemple si le nombre de lancers est de 100 en B3 alors INDIRECT(« J »&B3) renvoie J100 ;
    • NB.SI(plage;6) compte le nombre de fois où le chiffre 6 apparait dans la plage définie précédemment.

Par défaut le classeur est verrouillé pour éviter toute erreur de manipulation mais vous pouvez enlever la protection dans l’onglet « Révision », puis « Ôter la protection de la feuille ».

Télécharger le simulateur de lancers de dés

Pour récupérer le fichier, cliquer sur ce lien : simulateur de lancers de dés.

Commentez pour toute remarque ou question sur le simulateur de lancers de dés Excel !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.